Archive

Posts Tagged ‘Deployment’

DISM GUI 4.0 Beta Available

September 25, 2014 42 comments

It’s been a long time coming but I finally got around to updating my DISM GUI program to version 4.0.  I am treating this release as a beta as I have not had a chance to fully test everything yet.  You can find the download on the DISM GUI Codeplex site.

A few of the changes I implemented in this version

  • The .NET framework 4.0 is now required.  The previous version required 2.0.
  • Updated for DISM 6.3.  This version may work with older releases of DISM but some feature may not be available.
  • Added Capture and Apply tabs – This was the single most requested feature.  Requires DISM 6.2 or higher
  • Added a Read Only option to the mount control tab
  • Corrected some spelling errors

This version *should* run under WinPE however I have not tested it yet.  If anyone has success running it under WinPE make sure to leave a comment.

Preinstalling IE10 on Windows 2008 R2/Windows 7 could cause issues in MDT 2012

August 2, 2013 Leave a comment

I was updating our current Windows 2008 R2 image for MDT with all the latest security updates and ran into an annoying issue. After capturing the image and deploying it to VM (or a physical machine) I kept getting the error “Windows could not parse or process the unattend answer file for pass [specialize]”. I thought this was really odd because MDT created the Unattend.XML file for me. The same process has worked for me for over a year, why all of a sudden did it stop working?

I found my answer at this link. I must of accidently installed IE10 when doing my security updates. In the unattend.xml file there is a line for IE9 called . This does not existing in IE10 so it causes the specialize phase of Sysprep to fail. Below is a excerpt from the unattend.xml file that was causing the issue. You just need to comment out the line  <IEWelcomeMsg>  and you should be all set.

MDTImage

Categories: Deployment, MDT, Windows Tags: , ,

DISM GUI 3.5 Released

February 13, 2013 16 comments

It’s been almost a year since the last release but I just uploaded DISM GUI 3.5 to the Codeplex site this morning.  It contains a few background bug fixes and a few new features.  For this version I have kept it compatible with the Windows 7 WAIK and DISM version.

  • Added Edition Servicing tab
  • Added the ability to apply and unattend file
  • Added application servicing tab

It’s not a major release but adds most of the features available in the Windows 7 DISM program.  You will notice that there is no “online” functionality to allow it to operate on the running OS.  That is something I had planned to put in but was proving hard than I thought with the current version.  I’m hoping to include that in version 4.0

Speaking of version 4.0.  I don’t have a timeframe to release it yet but I do have some of the features planned.

  • Online mode – Allow DISM to be used against the currently running OS.
  • Windows ADK compatibility – The next version will rely on the Windows ADK and DISM version included in it.
  • WinPE compatibility – I am planning on making the next version work inside WinPE.
  • Powershell backend – This one is still up in the air but I may convert the backend to the new Powershell cmdlets instead of relying on DISM.exe.
      There might be more features added but this is what I am planning now.  If you have a suggestion add it to the

Codeplex

    site.

Codeplex DISM site

Using HP Proliant Broadcom NICs in WinPE

June 7, 2012 7 comments

We recently got in a new HP Proliant BL460c Gen8 blade with the HP 530FLB NIC. It’s a great piece of hardware but using the NIC in WinPE is not much fun.  We recently started using MDT to deploy Windows servers now but no matter what I did I could not get the NIC driver to load in WinPE.

Even though the drivers were imported into MDT and I had rebuilt my boot images it would not load.  Finally I ran HP’s driver installation utility from inside WinPE and it came up.  That’s when I discovered that the NIC needs the HP Virtual Bus Device driver loaded before it can load the NIC driver.  Looking at the PnP IDs that the driver supports I noticed they all start with b06bdrv\l2nd instead of the usual pci_<VenID>.  This is because the NIC virtual sits on top of another device. 

So why not just load the HP Virtual Bus Device in MDT?  That’s what I did but the HP Virtual Bus Device is a system-class driver and by default MDT does not copy system-class drivers into the boot images.  image

Sure you can configure it to add them but then your boot images will get much larger.  My solution was to instead put a copy of the HP Virtual Bus Device (evbd.inf) driver into my MDT boot image using the “Extra directory to add” feature in MDT.  I also imported the NIC drivers into MDT as I normally do. 

image

Once the boot image loads press F8 to open a new command window. Navigate to the folder you added to the MDT boot image (it should be right off the root) and enter drvload evbd.inf. After a few seconds the driver will load and the NIC should now be active. It’s not an ideal solution but since we don’t deploy a lot of these servers it works for me.  This same process would also apply to some of the other Broadcom NICs used in HP blades and servers like the NC373i and NC382i. 

Categories: Deployment, HP, MDT, Windows Tags: , , ,

Setup MDT 2012 to use USMT 3

May 15, 2012 4 comments

I recently upgraded our MDT 2010 Deployment share to 2012 and ran into an issue with USMT 3.  We still have some scenarios where we are deploying Windows XP so USMT 3 is required.  Whenever we ran a task sequence that needed the USMT 3 files we would get an error that the files could not be found.  I thought this was odd since the USMT 3 CAB file was in the correct location.  Or at least it was for 2010. 

In MDT 2010 you just had to leave the USMT30_x86.CAB file in the DeploymentShare\Tools\X86 folder and MDT took care of the rest.  With MDT 2012 you need to create a USMT3 folder in DeploymentShare\Tools\X86 and then unpack the CAB file into this folder.  It will not unpack the CAB file for you anymore.  Now MDT will be able to find the USMT files and continue.

Hopefully this helps out anyone else that has done an upgrade from 2010 to 2012.

Categories: Deployment, MDT Tags: , ,

DISM GUI 4.0 Feature Requests

February 20, 2012 60 comments

I’ve just started working on version 4 of DISM GUI and honestly I don’t know what features of DISM to add.  So I’m asking the community for some help here.

  • What features of DISM that you use often are missing from the GUI?
  • What changes to the graphical interface would you suggest?
  • Do you use DISM in online mode?  If so would having an online mode be a useful feature to add?

Most of my work with DISM GUI revolves around managing drivers and features but I understand my use case is not the same as everyone else’s.  I’ve tried to add what the I felt were the most used features of DISM to the application.  Leave some feedback here or head on over to the Codeplex site and leave your suggestion there.

Categories: DISM, DISM GUI Tags: , ,

Using MDT Queries to Assign Applications to Specific Hardware

October 26, 2011 1 comment

I was asked by a commenter (here you go Alan!) on expanding on how I use a Make and Model query to automatically assign applications to a specific hardware models.  It’s a very easy and powerful feature of MDT and it makes installing those OEM supplied utilities a lot easier.

I’m going to assume that you already have your SSM packages created in your MDT Applications.  If not refer to my post on them here.

The first thing you need to do is configure the MDT Configuration Database.  There are many articles on the internet that already cover this (including the MDT Documentation) so I won’t rehash that information.  One I found particularly good was this one.  After you have configured that database and the rules make sure you update your WinPE boot images.  If you don’t they will not be able to take advantage of the make and model queries.

Now that your database is configured and you have configured your rules (all explained in the previous link) you can use MDT to dynamically assign applications based on model.  In the Deployment Workbench go to Advanced Configuration > Database > Make and Model.

image

Right click Make and Model and choose New.  On the first screen you need to define your Make and Model as is represented in WMI.  It’s important that the Make and Model fields exactly match the Name (Model) and Vendor (Make) attributes store in the WMI database.  For those that don’t know how to find this information you can use the WMIC tool to display it.  The below command returns the Make and Model information from WMI.  Note that Name = Model and Vendor = Make.

wmic csproduct get /value

image

After you enter in the Make and Model information click on the Applications tab.  Click Add and choose the SSM application that you want to assign to this model.  You can assign as many as you want.  Each application that you add to this make and model will be automatically assigned when you choose a deployment task sequence.

Boot from you WinPE image and choose your deployment task sequence.  When you get to the screen to choose your applications the ones you previously added to the Applications tab should already be checked.

This is a great way to deploy OEM specific applications in an automated process but you can also do this with any application in MDT.

%d bloggers like this: